elementaryOS ships an urgent fix for AppCentre crash

The elementaryOS team has shipped an urgent fix for a critical bug that causes AppCentre crash. The issue was preventing updates in AppCentre from showing contents. Since the issue had reported, elementaryOS team was working closely to find the origin of issue and they have succeeded in their attempt.

It was figured out that, actual issue was rooting down to PackageKit, under the hood service of AppCenter for retrieving list of software packages and available updates. There was some deprecated piece of code named get-distro-upgrades in PackageKit maintained in elementary repositories. Though this code was patched, there were some hidden references to it and it was triggered following the release of base project, ie, Ubuntu 17.04. It was getting hanged while fetching update information and was preventing proper functioning of AppCenter. After figuring out this issue, elementary team has created a patch to resolve the issue and it is shipped as an update.

File Picture : elementaryOS AppCentre
Usually, elementaryOS team encourages updating software through AppCentre. But, this time there is no way other than falling back to command prompt as AppCentre updates are not working. elementaryOS users can get the fix using the sudo apt update & sudo apt upgrade commands.
You may have experienced a recent issue that caused updates in AppCenter to stop showing completely. You’ll be happy to know that we’ve been hunting down this issue with laser focus and have now issued a fix.

If you’re curious about what happened and what this fix is, read on! AppCenter uses a software library called PackageKit to do most of the important bits of fetching and installing software. The particular version of packagekit in our repos happened to have a patch designed to remove an unused function called get-distro-upgrades.  
You can find original announcement regarding bug fix on elementaryOS blog.

Share this

Related Posts