Installing XFCE 4.12 in Fedora 20/21


Recently XFCE developers announced release of XFCE 4.12, latest version of light weight desktop environment series specially designed for GNU/Linux, BSD distributions.
XFCE 4.12 In Fedora 21

In this article, I would like to share the steps to be followed for installing XFCE 4.12, on Fedora 20/21. Even though XFCE 4.12 is not officially available for Fedora, some Fedora contributors has prepared a repository for installing XFCE 4.12 on Fedora 20/21.

Step 1 : Install Copr XFCE4.12 Repository

First step for installing XFCE 4.12 is enabling Copr XFCE 4.12 repository. To enable Copr XFCE 4.12 repository, open terminal and type following command.
$ cd /etc/yum.repos.d

#Fedora 20 64bit and 32 bit
$ sudo wget https://copr.fedoraproject.org/coprs/nonamedotc/xfce412/repo/fedora-20/nonamedotc-xfce412-fedora-20.repo
[password]

#Fedora 21 64bit and 32 bit
$ sudo wget https://copr.fedoraproject.org/coprs/nonamedotc/xfce412/repo/fedora-21/nonamedotc-xfce412-fedora-21.repo
[password]


Step 2 : Install XFCE 4.12 

Now, we can install XFCE 4.12 as usual using either yum or dnf.
$ sudo yum install -y @xfce-desktop
[password]

After downloading packages, a signature acceptance will be required before continuing with installation
Retrieving key from https://copr-be.cloud.fedoraproject.org/results/nonamedotc/xfce412/pubkey.gpg
Importing GPG key 0x02E3DDFB:
 Userid     : "nonamedotc_xfce412 (None) <nonamedotc#xfce412@copr.fedorahosted.org>"
 Fingerprint: a8fe 2ac0 d349 43a6 e5eb 0eaa b1e8 4877 02e3 ddfb
 From       : https://copr-be.cloud.fedoraproject.org/results/nonamedotc/xfce412/pubkey.gpg
Is this ok [y/N]: y

This signature can be accepted just by typing 'y'.

Step 3 : Login to XFCE Desktop

We are done with basic installation of XFCE 4.12 Desktop. Now logout of your current desktop environment and select XFCE Session from login window. Then Login after entering your credentials.
First view of XFCE 4.12 in Fedora 21

Now what you see is a basic installation of XFCE 4.12 Desktop.
You can customize it as you wish.


Step 4 : Customize XFCE Desktop  

Now you can customize your desktop as you wish. I'm not listing detailed customization steps here. Just listing a few screen shots of configuration that I have done.
Changing Window Manager Theme

Customizing Panel

Customizing Appearance

Configuring Compositor to enable special effects

Share this

Related Posts

7 comments

comments
Anonymous
1 May 2015 at 09:56 delete

doesn't work... wrong instructions
sudo yum install -y "@xfce-desktop"
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* fedora: ftp.cica.es
* rpmfusion-free: mirrors.coreix.net
* rpmfusion-free-updates: mirrors.coreix.net
* rpmfusion-nonfree-updates: mirrors.coreix.net
* updates: ftp.cica.es

Reply
avatar
1 May 2015 at 11:17 delete

Can you please post complete output including error message? I have written this post, after experimenting myself.

Reply
avatar
Anonymous
19 May 2015 at 13:03 delete

Do we have to uninstall existing xfce packages first?

Reply
avatar
20 May 2015 at 07:35 delete

I'm not sure about that. I hope, just updating your system after enabling coprs repo will do your work.

Reply
avatar
Anonymous
23 May 2015 at 18:48 delete

Hi, nice post. I'm getting a dependencies error, I followed your tutorial and did exactly what you did. Result:
$sudo yum install -y @xfce-desktop
Loading mirror speeds from cached hostfile
...
--> Processing Dependency: libxfce4util.so.6()(64bit) for package: xfce4-xfswitch-plugin-0.0.1-11.fc21.x86_64 Requires: libxfce4util.so.6()(64bit)
Removing: libxfce4util-4.10.1-4.fc21.x86_64 (@koji-override-0/$releasever)
libxfce4util.so.6()(64bit)
Updated By: libxfce4util-4.12.1-1.fc21.x86_64 (nonamedotc-xfce412)
~libxfce4util.so.7()(64bit)
Error: Package: xfce4-wmdock-plugin-0.3.4-10.fc21.x86_64 (@fedora)
Requires: libxfce4util.so.6()(64bit)
Removing: libxfce4util-4.10.1-4.fc21.x86_64 (@koji-override-0/$releasever)
libxfce4util.so.6()(64bit)
Updated By: libxfce4util-4.12.1-1.fc21.x86_64 (nonamedotc-xfce412)
~libxfce4util.so.7()(64bit)
Error: Package: xfce4-kbdleds-plugin-0.0.6-6.fc21.x86_64 (@fedora)
Requires: libxfce4util.so.6()(64bit)
Removing: libxfce4util-4.10.1-4.fc21.x86_64 (@koji-override-0/$releasever)
libxfce4util.so.6()(64bit)
Error: Package: xfce4-radio-plugin-0.5.1-9.fc21.x86_64 (@fedora)
Requires: libxfce4util.so.6()(64bit)
Removing: libxfce4util-4.10.1-4.fc21.x86_64 (@koji-override-0/$releasever)
libxfce4util.so.6()(64bit)
Updated By: libxfce4util-4.12.1-1.fc21.x86_64 (nonamedotc-xfce412)
~libxfce4util.so.7()(64bit)
Error: Package: xfce4-embed-plugin-1.4.1-3.fc21.x86_64 (@fedora)
Requires: libxfce4util.so.6()(64bit)
Removing: libxfce4util-4.10.1-4.fc21.x86_64 (@koji-override-0/$releasever)
libxfce4util.so.6()(64bit)
Updated By: libxfce4util-4.12.1-1.fc21.x86_64 (nonamedotc-xfce412)
~libxfce4util.so.7()(64bit)
Error: Package: xfce4-cpufreq-plugin-1.0.0-10.fc21.x86_64 (@fedora)
Requires: libxfce4util.so.6()(64bit)
Removing: libxfce4util-4.10.1-4.fc21.x86_64 (@koji-override-0/$releasever)
libxfce4util.so.6()(64bit)
Updated By: libxfce4util-4.12.1-1.fc21.x86_64 (nonamedotc-xfce412)
~libxfce4util.so.7()(64bit)
Error: Package: xfce4-smartbookmark-plugin-0.4.4-9.fc21.x86_64 (@fedora)
Requires: libxfce4util.so.6()(64bit)
Removing: libxfce4util-4.10.1-4.fc21.x86_64 (@koji-override-0/$releasever)
libxfce4util.so.6()(64bit)
Updated By: libxfce4util-4.12.1-1.fc21.x86_64 (nonamedotc-xfce412)
~libxfce4util.so.7()(64bit)
Error: Package: xfdashboard-0.3.91-1.fc21.x86_64 (@updates)
Requires: libxfce4util.so.6()(64bit)
Removing: libxfce4util-4.10.1-4.fc21.x86_64 (@koji-override-0/$releasever)
libxfce4util.so.6()(64bit)
Updated By: libxfce4util-4.12.1-1.fc21.x86_64 (nonamedotc-xfce412)
~libxfce4util.so.7()(64bit)
Error: Package: xfce4-cellmodem-plugin-0.0.5-14.fc21.x86_64 (@fedora)
Requires: libxfce4util.so.6()(64bit)
Removing: libxfce4util-4.10.1-4.fc21.x86_64 (@koji-override-0/$releasever)
libxfce4util.so.6()(64bit)
Updated By: libxfce4util-4.12.1-1.fc21.x86_64 (nonamedotc-xfce412)
~libxfce4util.so.7()(64bit)
Error: Package: xfce4-wavelan-plugin-0.5.11-6.fc21.x86_64 (@fedora)
Requires: libxfce4util.so.6()(64bit)
Removing: libxfce4util-4.10.1-4.fc21.x86_64 (@koji-override-0/$releasever)
libxfce4util.so.6()(64bit)
Updated By: libxfce4util-4.12.1-1.fc21.x86_64 (nonamedotc-xfce412)
~libxfce4util.so.7()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Reply
avatar
24 May 2015 at 09:59 delete

Do you have older version of XFCE installed in your system?

Reply
avatar
24 May 2015 at 10:00 delete

Yeah. It appears that, you have XFCE 4.10 already installed in your system. You can solve this issue as given here.
https://ask.fedoraproject.org/en/question/66432/error-installing-packages/

Reply
avatar